Georeferencing Raster Layers (in-place tool)

This section covers the original Cartographica In-Place georeferencing tool. For most georeferencing needs, we suggest using the newer Georeferencing Raster Layers (side-by-side) tools, introduced in version 1.5. 

There are times when raster data is delivered without spatial reference information. If you have an ungeoreferenced image, you will need to georeference it before it will show up correctly on the Map. In these cases, Cartographica can be used to adjust the images for their location, a process called Georeferencing.

Georeferencing is always a difficult an tedious task, and if there's a possibility that the spatial components exist for the raster files you are working with, you should seek these out.

Cartographica has the ability to georeference raster data manually through the use of Ground Control Points or georeference matrices. Georeferencing involves telling Cartographica the location and size of the raster image relative to some known Coordinate Reference System (CRS), so that it can be displayed correctly along with other data. In order to appropriately georeference an image, you will need to have some form of reference layer, such as a vector map of the area or a live map.

Georeferencing Raster Layers
  1. Make sure you have a reference layer loaded, unless you are manually setting the matrix or ground control points. A vector map of the area or a live map are often good choices for this.
  2. Verify that your reference layer is included in the Map Extent. This will be the default for most Vector and Raster layers, but not for Live Map layers. Select the reference layer in the Layer Stack and the make sure   Layer > Include in Map Extent is checked.
  3. Load your Raster layer by using drag-and-drop or   File > Import Raster Data...
  4. Click on the new Layer in the Layer Stack to select it
  5. Choose  Layer > Set Layer's Projection to choose the CRS in which the layer will be referenced (usually the same as the current map or the reference layer).
  6. Zoom and pan the reference layer until you can see a location that is basically the same area as the area of the raster layer. Ignore for the time being the raster layer, since it likely will be very far away from its actual location to start with.
  7. Choose  Edit > Georeference Image… to begin the georeferencing
  8. At this time, the Georeference panel should come up, providing control over the georeference process. By default, it starts in Ground Control Point mode, which allows you to drag the dots in order to match points in the reference layer.
  9. Click Fit Display
    At this time, the Raster image should be visible on the screen (although probably not in exactly the right place). 
  10. If your raster layer appears upside down, click Flip Vertical to correct that.

    On a machine with a trackpad, you can adjust the image's size and rotation using pinch and zoom and rotate.
    Arrow keys can be used to "nudge" the position of the raster image

  11. The mouse can be used to move the existing four corner GCPs so that they align with data in the reference layer
    If you hold the Option (Alt) key down and click, you can create new GCP anywhere within the image. Option-click on the image to create the reference and drag to the point in the reference layer that represents that location. With more than 4 locations, a minimum of 7 GCPs is suggested for smooth representation.
  12. When you are done with the georeferencing, choose  Edit > Georeference Image… to end the edit