Referenced Data

Cartographica tries to be intelligent about referencing external data in order to maximize efficiency and convenience. In many cases, Cartographica can make an external reference to a file instead of making it part of the Mapset. This data is referred to as being Externally Referenced.

When a layer is Externally Referenced, it has a by reference icon () in the layer stack on the right side. Also, when that layer is selected, the Layer > Include Layer Data in Mapset item is unchecked.

Often, storing boilerplate data and large imagery in external files is desired to save space and to make updating that data easy. Imagine having a set of 10 maps that all need road information, but your road information changes on a monthly basis. If your road polygons are kept in an external file, you need only update the external file, load your mapset and the information is up-to-date.

The main reason to use this is if you need to "Freeze" the data for a particular layer so that you don't accidentally change it.

Bringing External data into the Mapset
  1. Select the desired layer from the Layer Stack
  2. Choose Layer > Include Layer Data in Mapset to bring the data into the Mapset. The next time you save, a copy of the data will be made inside of this Mapset.
    Once a data set it brought into the Mapset, the only way to make it external again is to delete the layer with the internal copy and re-import the data.

Occasionally, you may need to create a copy of a Cartographica Mapset for distribution to other parties or to archive the complete state of a map and all its constituent parts. In this case, often it is necessary to put all of the data into the Mapset file before sending it because the recipient may not have the original files. Since permanently changing this might not be desired, you can save a copy of your Mapset file that has had all of its layer data brought internal, or "flattened".

Flattening a Mapset
  1. Choose File > Save As… to begin the saving process
  2. Check  Flatten Map When Savingto flatten the file
  3. Now choose a file name and click  Save